Mikrotik Setting Dynamic DNS with Script

Posted: August 30, 2016 in Netwok

http://wiki.mikrotik.com/wiki/Dynamic_DNS_Update_Script_for_No%ADIP_DNS
Open Mikrotik Winbox, Go to System –> Script
clip_image002 
Create New Script
clip_image004
clip_image005

Script
#######################################################################################
# No-IP automatic Dynamic DNS update
#————— Change Values in this section to match your setup ——————
# No-IP User account info
:local noipuser "your_no-ip_user"
:local noippass "your_no-ip_pass"
# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas. :local noiphost "hostname.no-ip.net"
# Change to the name of interface that gets the dynamic IP address
:local inetinterface "your_external_interface"
#————————————————————————————
# No more changes need
:global previousIP
:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
:local currentIP [/ip address get [find interface="$inetinterface" disabled=no] address]
# Strip the net mask off the IP address
:for i from=( [:len $currentIP] – 1) to=0 do={
:if ( [:pick $currentIP $i] = "/") do={
:set currentIP [:pick $currentIP 0 $i]
}
}
:if ($currentIP != $previousIP) do={
:log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"


:set previousIP $currentIP
# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
:local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
:local noiphostarray
:set noiphostarray [:toarray $noiphost]
:foreach host in=$noiphostarray do={
:log info "No-IP: Sending update for $host"
/tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
:log info "No-IP: Host $host updated on No-IP $previousIP with IP $currentIP – IP Tidak Berubah"
}
} else={
:log info "No-IP: Previous IP $previousIP is equal to current IP, IP berubah"
}
} else={
:log info "No-IP: $inetinterface is not currently running, so therefore will not update."
}
#######################################################################################
Create Schedule, Go to System –> Scheduler
clip_image007
clip_image009
Create New Schedule
clip_image010
Check Script running on log Mikrotik
clip_image011
CMIIW, Thanks  Smile

Leave a Reply

Your email address will not be published. Required fields are marked *