Archive for the ‘Linux’ Category

# a2ensite default-ssl

# a2enmod ssl

# service apache2 restart

# vi /etc/apache2/ports.conf

clip_image001

(more…)

Setting IP Mikrotik

To see interface NIC

[admin@MikroTik] > interface print

Flags: D – dynamic, X – disabled, R – running, S – slave

# NAME TYPE MTU

0 R PFSense ether 1500

1 R NetZap ether 1500

2 R LAN ether 1500

IP WAN :

[admin@MikroTik] > ip address

[admin@MikroTik] /ip address> add address=172.16.1.30/24 interface=PFSense

IP LAN :

[admin@MikroTik] /ip address> add address=10.10.10.1/24 interface=LAN

(more…)

Clear Cache Proxy Squid Di Debian Etch

Posted: January 27, 2010 in Linux

Squid adalah salah satu cache server yang tugasnya secara global adalah menyimpan aktifitas surfing internet kita, sehingga akan menghemat bandwidth yang dipakai karena sekali kita browsing ke suatu situs maka situs tersebut akan disimpan kedalam cache Proxy kita, sehingga ketika orang lain atau kita sendiri membuka situs yang sama maka akan terasa lebih cepat dan menghemat bandwidth.

Langkah-langkah menghapus Cache Squid :

1. Stop proses SQUID yang sedang berjalan

# /etc/init.d/squid stop

2. Bersihkan semua direktori swap proxy

# rm –fdR /var/spool/squid/* (pada proses ini sedikit memakan waktu)

3. Membangun kembali direktori swap yang baru

# squid –z

4. Menjalankan kembali Squid Proxy

# /etc/init.d/squid start

Lupa Password Di Debian Etch

Posted: January 25, 2010 in Linux

1. Pada prompt grub-boot
Tekan tombol “e” untuk masuk ke mode edit
2. Kemudian tekan tombol panah bawah untuk memilih baris yang dimulai dengan “kernel” (jangan di “enter” dulu)
Tekan “e” lagi
3. Pada bagian terakhir baris tersebut tambahkan “init=/bin/sh” atau “/bin/bash”
4. Lalu tekan “enter” untuk merubahnya dan kemudian tekan “b” untuk boot.
Dalam beberapa saat akan muncul prompt “#”
5. Ketik “mount -o remount rw /”
Dalam beberapa kasus, file system root di mount read only
6. Langkah terakhir, ketik “passwd” dan akan muncul prompt change password.
Setelah ganti password ketik “init 6″ atau “reboot”

Text Editor vi

Posted: January 25, 2010 in Linux

Contributed by ipong

vi merupakan teks editor interaktif yang dapat digunakan untuk membuat dan memodifikasi suatu file text. Teks editor ini dibuat oleh Bill Joy dari Universitas California, Barkeley, USA. Editor vi nyaris digunakan di semua varian Unix. Penggunaan huruf besar dan huruf kecil di vi akan menghasilkan hal yang berbeda.

Untuk menjalankan vi, format perintah nya di shell adalah :

vi [option] [namafile]

Mode dalam vi

Ada 3 mode dalam vi, yaitu :

1. Command Mode

Maksudnya, mode dimana user dapat menggerakkan kursor, menghapus, mensubtitusi, mencari suatu string. Secara default, waktu pertama kita masuk ke dalam text editor vi, kita di tempatkan pada mode ini. Berikut yang sering dipakai :

Menggerakkan kursor

h => satu karakter ke kiri

1 => satu karakter ke kanan

k => satu baris ke atas

j => satu baris ke bawah

  (more…)

Setting IP Address Di Debian Etch

Posted: January 25, 2010 in Linux

mail:/home/vicry# vi /etc/network/interfaces

auto lo
iface lo inet loopback

iface eth0 inet static
address 172.16.1.3
netmask 255.255.255.0
gateway 172.16.1.1

auto eth0

mail:/home/vicry# vi /etc/resolv.conf

nameserver 172.16.1.1

Tutorial iptables

Posted: January 17, 2010 in Linux

untuk melihat nat routing yang aktif
iptables -nL -t nat

untuk menghapus nat
iptables -t nat -D PREROUTING 2
NB : 2 itu adalah urutan dalam list

untuk membuka port vnc dari router ke lan
iptables -t nat -A PREROUTING -i eth1 -p tcp –dport 5900 -j DNAT –to 172.16.1.12:5900

untuk membuka port 25 ke local dari router
iptables -t nat -A PREROUTING -i eth1 -p tcp –dport 25 -j DNAT –to 172.16.1.3:25

untuk save

iptables-save > /etc/iptables.conf

#echo "iptables-restore < /etc/iptables.conf" >> /etc/network/if-up.d/iptables

#chmod 755 /etc/network/if-up.d/iptables

Untuk Menghapus aturan-aturan yang sudah ada dengan perintah sebagai berikut:

iptables –flush

iptables –table nat –flush

iptables –delete-chain

iptables –table nat –delete-chain

Membuka Port RDP dari Router Ke Client Windows

tambahkan ini pada /etc/squid/squid.conf agar port 3389 di kenal oleh squid
acl Safe_ports port 3389        # RDP
lalu buat port forward sesuai yang kita inginkan
iptables -t nat -A PREROUTING -i eth1 -p tcp –dport 3389 -j DNAT –to 172.16.1.12:3389